###

alias hbin me

Vagrant plugin - vbguest

Yestoday, I upgraded my VirtualBox from version ‘4.2.18’ to ‘4.3.6 along with upgraded the vagrant to '1.4.3’.

After I run vagrant up I got a warning message:

1
2
3
4
5
6
7
8
9
[default] The guest additions on this VM do not match the installed version of
VirtualBox! In most cases this is fine, but in rare cases it can
prevent things such as shared folders from working properly. If you see
shared folder errors, please make sure the guest additions within the
virtual machine match the version of VirtualBox you have installed on
your host and reload your VM.

Guest Additions Version: 4.2.18
VirtualBox Version: 4.3

After a google, I found that there is a plugin which can automatically installs the host’s VirtualBox Gest Additions on the gest system.

Here is the repo address: https://github.com/dotless-de/vagrant-vbguest

And that solved my problem.

Comments